Problema de ruidos en circuito activo [TP4056 - Bateria - MT3608]

Dokken
#1 por Dokken el 26/09/2019
Buenas!

Había publicando la consulta en la sección de taller, pero creo que encaja mejor en esta subsección, he avisado para que borren el otro hilo.

Al lio!,estoy haciendo un pequeño experimento con circuitería activa (EMG 81), en el cual me están surgiendo unos pequeños problemas.

Explico un poco lo que estoy tratando de hacer. Mi idea es evitar usar pilas de 9v para la alimentación de una pastilla EMG 81, para ello uso estos tres elementos:

- Placa TP4056 (cargador de baterías de litio).
e58bafc8a8ea0443f3336738c7644-2465455.jpg

- Placa MT3608 (conversor de voltaje step by step). Voltaje de entrada 2-24v y voltaje de salida de 5-28v con corriente max de salida de 2A.
5094c7bd7199b7258a0115acab815-2465455.jpg

- Batería Litio de 2000mah a 3.7v.

La conexión que probé fuera de la guitarra es, TP4056 conectado a la batería (positivo y negativo), y positivo y negativo a la entrada del MT3608. Midiendo con el polímetro, a la entrada del MT3608 tengo los 3.7v de la batería y a la salida (regulando el potenciometro) obtengo los 18v que quiero ponerle a la EMG. Adicionalmente el TP4056 carga correctamente la batería de litio, hasta aquí ningún problema.

A la hora de meter todo a la guitarra, mantengo la misma conexión anterior, sacando el positivo de 18v a la EMG y el negativo al jack stereo para cerrar el circuito.

El problema viene cuando enchufo la guitarra al ampli, aparece un ruido fuerte de masa (he revisado todas las conexiones y no hay derivaciones, cables sin soldar ni nada similar, estoy usando un solo potenciometro de volumen). En este caso (con ruido) la guitarra suena, y comprobando la tensión en todos los puntos da la lectura correcta (3.7v a la entrada del MT3608 y 18v a salida).

El caso es que toqueteando, uní sin querer el positivo y negativo del MT3608, aquí el ruido desapareció y la guitarra sonaba perfecta, pero a la hora de medir los voltajes en vez de 3.7-18v me daba 1.9-1.7v, algo que no entiendo porque sucede. También me fijé que aunque el ruido desaparezca, si conecto el cargador usb a la TP4056 para cargar la batería me vuelve a sonar el ruido y tengo que hacer el "puente" anterior para eliminarlo.

¿Alguien se le ocurre porque puede estar sucediendo esto?

Estos son los dos esquemas de cableado que he probado:

Los 0v de referencia los obtengo conectando la batería al pin del Jack que se une a la masa una vez conectas el Jack.

5fb433ebe506aaebdf95b627fdfeb-2465455.jpg

Esta es la otra conexión que probé, el problema es que al quitar el Jack se interrumpe la alimentación a 18v pero la batería sigue alimentando el MT3608.
00930cad534568d35fd3a29209293-2465455.jpg
Subir
Dokken
#2 por Dokken el 26/09/2019
Creo que he dado con uno de los problemas.

Lo que comentaba de que cuando hacía un "corto" se quitaba el ruido pero me bajaban los voltajes. Revisando el datasheet del MT3608 he visto que tiene una entrada marcada como "EN" la cual recibe voltaje para encender o apagar el MT3608.

Tal y como lo tengo conectado, está recibiendo siempre los 3.7V de la batería, ya que el positivo no se corta en ningún momento, digamos que siempre está activo el MT3608. Al puentear la entrada con tierra le mete 0V y pasa el circuito a OFF, evita el ruido pero claro, no saca los 18V de la conversión.

Acotando un poco más el problema, parece que al estar ON el MT3608 la bobina mete ruido en el circuito de audio y de ahí el sonido. Ahora toca ver como puedo tener los 18v pero sin tener ningún tipo de ruido en el sistema.


Otro requisito que parece que va a tener que ser necesario, es cortar el positivo de entrada al MT3608 con el jack stereo, en vez de cortar el negativo. Habrá que dar una pensada a ver como puede hacerse
Archivos adjuntos ( para descargar)
Captura de pantalla de 2019-09-26 12-40-18.png
Captura de pantalla de 2019-09-26 12-40-46.png
Subir
ignotus
#3 por ignotus el 27/09/2019
Buenas, yo he hecho alguna cosa con un montaje muy parecido, pero con un conversor DC-DC de 5v. Si mides continuidad entre los negativos del TP4056 (entrada y salida de batería), verás que no hay - es decir, no es lo mismo el negativo del conversor que el de la entrada al TP4056 desde la batería. Para que lo tengas en cuenta al hacer las conexiones.

Por otro lado, para resolver el tema de cortar el circuito sacando el jack, no lo hagas cortando el positivo conectándolo al jack - no se puede porque entonces ¿qué haces con la masa del 'sleeve'? Haz el corte entre la salida del negativo del TP4056 y la entrada al conversor.

Luego lo del ruido. En mis circuitos no hay señales de audio, pero sí para medición de voltaje, y esos conversores son muy guarros en cuanto a ruido. Yo lo he solucionado más o menos con condensadores puestos entre los polos del conversor. No controlo mucho pero con un electrolítico de 100uf y un cerámico de 100nf en paralelo me ha ido bien.
Subir
Dokken
#4 por Dokken el 27/09/2019
#3 Muchas gracias tío! Esta tarde haré varias pruebas.

Entiendo que entre los dos negativos entrará en juego el integrado que creo que tiene algún transistor que hace que abra y cierre el circuito. Por lo que lei, parece que la bobina acumula corriente, cuando el transitor cierra genera voltaje en el condensador de salida que va acumulando el valor que se haya ajustado. Por lo que para mantener el voltaje estable resaliza varios microcortes en el circuito para ir cargando la bobina y pasando corriente al condensador de salida.

Para el tema de cortar el positivo he estado mirando Jack DPDT y SPDT que tienen contactos N.A (Normalmente abierto) y N.C (Normalmnete cerrado), de esta forma podría cortar tanto negativo como positivo al sacar el jack.

Para el tema del ruido probaré lo que comentas de los condensadores ;). Imagino que se podría solucionar con filtros, pero tendría que saber que frecuencia tiene el ruido para tratar de filtrarla.

Un saludo!
Subir
ignotus
#5 por ignotus el 27/09/2019
Dokken escribió:
Para el tema de cortar el positivo he estado mirando Jack DPDT y SPDT que tienen contactos N.A (Normalmente abierto) y N.C (Normalmnete cerrado), de esta forma podría cortar tanto negativo como positivo al sacar el jack.
No tienes por qué complicarte tanto. Conecta el out (-) del MT3608 directo a tierra. Luego la salida (-) del TP4056 la conectas a 'ring'. Ya está - ya no alimentas el conversor (que te iría gastando la batería) y por tanto el resto del circuito. El TP4056 no consume nada aunque la batería la tenga conectada todo el tiempo.
Subir
Dokken
#6 por Dokken el 27/09/2019
#5 pues no había caído en esa distribución de los negativos. Voy a ver si esta tarde prolongó los cables y voy probando todo desde la protoboard, que será más fácil de conectar y desconectar para ir probando.
Subir
Dokken
#7 por Dokken el 27/09/2019
He conectado las masas como me dijo Ignotus y perfecto, corta voltaje al quitar el jack y no se queda nada alimentado.

Pero sigue haciendo ruidillos, he probado a poner el electrolítico de 100uF y el cerámico de 100nF en paralelo a la salida del MT3608 y se cortaba el sonido completamente. He probado a poner el de 100nF entre el cable que saca la señal y masa, ahí he conseguido bajar bastante el ruido. Luego le he metido un electrolitico de 2.2uF entre Vout del MT3608 y la masa, he conseguido bajar un poco más, pero se me queda un ruido bastante agudo que cuando subo el volumen mucho se nota un huevo.
Subir
ignotus
#8 por ignotus el 27/09/2019
Por lo que he leído esos conversores DC-DC baratos tienen un problema de ruido bestial que no se soluciona con un par de condensadores, por lo visto haría falta un circuito más complejo. Para lo que lo uso yo me hace el servicio, pero se ve que para circuitos de audio dan más problemas al derivar un montón de ruido a tierra. Solo se me ocurre usar un regulador LM7818 detrás del MT3608, subiendo el voltaje de este último, pero no sé si eso daría resultado. Algo como esto pero sin el puente rectificador.
Subir
Dokken
#9 por Dokken el 27/09/2019
#8 si, me temo que habrá que mirar alguna opción más compleja.

Con el LM7818, te refieres a alimentar el LM con el MT3608, no?
Subir
ignotus
#10 por ignotus el 28/09/2019
#9 Eso es.
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo