Footswich

Joseba Cilarte
#1 por Joseba Cilarte el 27/01/2009
Hola cuadrilla!

Estoy intentando adaptar el footswich de un marshall para activar el compresor y el control de tono de una pedalera Boss ME-50.

El caso, es que, funcionar, lo que es funcionar, funciona, pero me lleva de cabeza porque para activar o desactivar una u otra función tengo que presionar dos veces para activar y dos veces para desactivar.

He revisado todas las conexiones y estan bién. El conmutador no es DPDT ni 3PDT. Es un simple interruptor de tres posiciones. En la central el tip o el ring y en una de las dos de al lado la masa.

Les he quitado el led y la resistencia por si acaso era por eso, pero sigue igual.

¿Alguien me puede iluminar? O directamente este tipo de interruptores no sirven para eso.

PD: He probado con otro pedal idéntico y hace lo mismo, en cambio, para el cambio de canales del ampli va de lujo, con una sola pisada cambia.
Subir
David
#2 por David el 27/01/2009
mmmmmmmmmm

Creo que se lo que le pasa.

Vamos a ver. Te funciona en el amplificador porque en el amplificador lo que hace el pedal es activar o desactivar cierto rele y para eso lo que se necesita es dejar un circuito y mantenerlo cerrado.

Lo que ocurre es que como lo que quieres controlar un aparato digital, la conmutacion la hace el propio micro.

Pues bien, en los micros para que conmuten de canal hay que provocarles una interrupcion. En este caso la interrupcion se provoca con el pedal de switch.

Pero que ocurre, que estas interrupciones se suelen provocar por flanco de subida o de bajada. Me explico:

Cuando tu activas el pulsador pasas la señal de cierto nivel a otro mas alto o al reves (niveles de tension). El micro lo que detecta son esos cambios de nivel y ahi se activa la conmutacion.

Por eso a ti te ocurre que al activar el interruptor, este factor es importante, necesitas darle dos veces porque en una subes el nivel y en otra lo bajas, por ejemplo.

Podria ser al reves.

En ese caso al darle por segunda vez bajaria el nivel y el micro lo detectaria cambiando de canal.

Ese es tu problema, creo.

Para solucionarlo, no hay mas que sustituir el interruptor por un pulsador con le mismo patillaje:D.

Suponiendo que el problema venga de ahi que yo creo que es lo mas probable.

Puedes hacer una prueba rapida: Coje tu interruptor, identifica los cables que intervienen en el asunto y los contocircuitas rapidamente para volver luego a dejarlos normales, con un destornillador por ejemplo. Si el problema es por lo que yo digo, deberia de conmutar bien.

Espero que te sirva:D

Si tienes alguna duda pregunta;)

:saludo:
Subir
Joseba Cilarte
#3 por Joseba Cilarte el 27/01/2009
Ok, probaré esa solución a ver que tal.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo