DIY octaswitch

#37 por frasco el 24/10/2009
creo que hay proyectos parecidos
mas simples

pero este será nuestro

sin clonar.

:saludo:

Ya'sstamos.... ¿o no estamos a lo que estamos?

La web del luthier aficionado.

http://www.audiocosas.es/villagarlopa

Subir
#38 por drantar el 24/10/2009
Si, adelante ingenieros de lo imposible.... machaquemos a esos gringos !! :brindis:
Rublalup y yo solamente podemos dar ánimos, porque otra cosa....:p
PD: ¿entonces pillo unos dips 10 de esos chulis? :no_lo_se: ¿y 3PDT's? ¿Al final de cuantos efectos y bancos será? ¿va a tener salida para afinador también? ¿y blutuz? (nose, pero manos libres si :risa:, si no...mal vamos) ¿y UHF?
Subir
#39 por David el 24/10/2009
Bueno gente, me alegra deciros que segun las simulaciones que he hecho, el circuito parece funcionar a la perfeccion :aplausos:

Solo comentar que las resistencias de pull-down estaban mal diseñadas. Las he cambiado todas momentaneamente por unas de 1k y todo va como la seda. Las resistencias eran tan grandes que en reposo la tension en D0..7 era de unos 2-3 voltios :shock: a causa de la corriente de entrada de los latch. Habia un uno logico ya en reposo :shock:... Lo mismo ocurria en el terminal C.

A causa de esto, toda la parte de entrada estaba completamente despolarizada... un caos, vamos :D

Habria que pensar tambien en introducir un pequeño circuito de reset en el diseño porque al encender se nos pueden activar simultaneamente varias salidas del latch y liar la de dios ahi (que tampoco pasaria nada, se podrian activar a la vez varios pedales y si tenemos algo conectado que se produzcan acoples o algo por el estilo). Se implementaria haciendo el tipico circuito Vcc -> condensador -> resistor -> masa y llevando la union del condensador y la resistencia con un diodo al terminal C como si de un pulsador de cambio de canal se tratase, pero que solo se activase una vez al encender el cacharro.

En otro orden de cosas, que tal diseñar tambien una fuente de alimentacion para enchufar todos los pedales? Como la caja seria grande y para tantos reles hace falta una corriente significativa, interesaria meter un trafo dentro para alimentarlos. Podriamos aprovechar y de ahi sacar unas cuantas tomas para pedales tranquilamente :D

:saludo:
Subir
#40 por phakkito el 24/10/2009
Dcr, viendo el datasheet del chip, hay que ver la corriente que entrega en reposo, que en estos casos es minima pero existe si.

el valor 100k era excesivo a todas luces ;) solamente estaba como patron.

para un nivel bajo lo mejor es una R de 4k7.

El reset hay que ajustarlo, pero a la vez que no sea demasiado lento para un uso normal.
No podemos estar pulsando el canal y que tarde 1 segundo en activarse.

ya tengo un buen simulador y el lunes los integrados insitu... ya contaremos..

un saludo

La vida es muy peligrosa. No por las personas que hacen el mal, sino por las que se sientan a ver lo que pasa.

Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.

Subir
#41 por cermial el 24/10/2009
Buenas, yo hace tiempo vi a alguien de un foro preparandose un looper asi, lo que no me acuerdo donde lo vi XD¡, lo hizo con reles. Bueno, no estoy seguro si podia hacer agrupaciones y esas cosas que hacer mucho que lo vi. voy a buscar por si me lo baje, por si os sirve de ayuda
Subir
#42 por David el 24/10/2009
Con 4.7k sigue siendo excesivo, phakkito. Al simular, los niveles bajos estan por encima de VIL MAX que segun el datasheet vale 0.7V. Con la resistencia de 1k, este valor es un poco menor de 400mV y con la de 4.7k, el valor es de unos 1.3V...
Subir
#43 por bassiot el 24/10/2009
Dcr escribió:
Con 4.7k sigue siendo excesivo, phakkito. Al simular, los niveles bajos estan por encima de VIL MAX que segun el datasheet vale 0.7V. Con la resistencia de 1k, este valor es un poco menor de 400mV y con la de 4.7k, el valor es de unos 1.3V...


Lo que yo pensaba...
POr Diosss!!! en que idioma esta eso?? si parece extraterrestre, coñ...
Sois unos maquinas. :ok:
:saludo:

Y ahora a ver donde he dejado la pua....

Subir
#44 por phakkito el 24/10/2009
Dcr escribió:
Con 4.7k sigue siendo excesivo, phakkito. Al simular, los niveles bajos estan por encima de VIL MAX que segun el datasheet vale 0.7V. Con la resistencia de 1k, este valor es un poco menor de 400mV y con la de 4.7k, el valor es de unos 1.3V...



Visto el datasheet en condiciones... VIL de 0.8 para la serie LS, con ILow de 250uA, la resistencia tiene que estar por debajo de 2k.

Asi que el pulldown de 1k - 1.5k es el correcto ;) Esto de usar papel y lapiz es lo que tiene, yo calcule también con el divisor que montan los diodos y la resistencia del Lach enabled :D

El reset ya lo tengo...el D1 esta conectado a los 20mS.

Se puede poner un preset siempre o dejarlo en truebypass. Eso lo dejo a vuestra elección.

Otro problema que he encontrado con el simulador, es que al ser pulsadores, no hacia el lach bien, vamos no cerrojaba el dato a la salida.
Le he implementado un reset a Enabled, y abre y cierra en la pulsacion, con esar pulsado unos milisegundos, libera para el nuevo dato, y cierra anclando la salida.

He usado unos circuitos simples. Un transistor para la entrada del lach y otros dos para accionar el primer pulsador automáticamente y quede el loop listo para su uso.

En cuanto sepa como puedo subir algo del simulador lo paso.:oops: (con un dia de uso no doy pa estudiar mas :D )


Ni que decir tiene que esto se puede hacer mas sencillo o mas complejo...
Lo estamos preparando para 8 pedales...pero se puede hacer para tres o cuatro presets que es lo mas normal dentro de nuestro mundillo.

Un saludo.

La vida es muy peligrosa. No por las personas que hacen el mal, sino por las que se sientan a ver lo que pasa.

Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.

Subir
#45 por David el 25/10/2009
phakkito, que simulador estas usando? Yo probe con el Orcad pero hacia lo que le daba la gana y luego me pase a otro que usaba hace mucho tiempo que se llama proteus.

Lo bueno que tiene el proteus este es que es muy interactivo y no como el Orcad... Por ejemplo, para simular este circuito, puedes poner los pulsadores, etc, e interactuar con ellos mientras se simula el circuito (simulacion en tiempo real) y ver como evolucionan las tensiones mediante osciloscopios en los que conectas las señales que quieras ver. Si pones potenciometros, tambien los puedes variar con la simulacion corriendo, etc.. Lo que se te ocurra. Una gozada, vamos :D

Mirad estas capturas. Lo bueno que tiene este programa tambien es que en los terminales de los componentes sale un cuadradillo que se ilumina dependiendo del nivel logico que haya. Si estamos en un 1, sale de color rojo; si estamos en un 0, sale de color azul y si estamos en incertidumbre, sale sin colorear.

Aqui el esquematico sin correr la simulacion todavia:

299664ae385b2ab27a.jpg

Ahora miramos la siguiente foto ya en simulacion. Fijaos en los niveles logicos que marcan los cuadradillos: En la salida los reles estarian activados si nosotros asi lo quisieramos por los microinterruptores. De ahi la necesidad de un reset inicial por si acaso.

Tambien sale un poco del osciloscopio. Fijaos que el valor en reposo de las lineas de entrada es de 377mV (inferior a 700-800mV que es lo que interesa):

299664ae38751df3fe.jpg

Le metemos una patada al pulsador de arriba y mantenemos pulsado. ¿Que pasa? Aqui sale:

299664ae3888da18e8.jpg

Fijaos en las lucecitas de salida del chip de enmedio: Esta en rojo la de arriba y las demas en azul. Esto significa que tenemos seleccionado el preset 1 como queriamos y los demas estan desactivados. Si vamos un poco mas alla al grupo de microinterruptores de arriba, se ve que el primer microinterruptor esta activado y este esta controlando al rele de arriba del todo. Si miramos al amperimetro que hay arriba del rele, se ve como marca 0.02A -> nuestro rele funciona y tenemos el pedal 1 metido en la cadena de efectos. Si tuviesemos mas microinterruptores encendidos, controlariamos mas reles y mas pedales, pero no iba a simularlos todos a la vez sabiendo que funciona uno :oops:

Terminamos de meterle el patadon al pulsador de preset. ¿Que pasa?

299664ae38b911022d.jpg

Las entradas vuelven a la situacion de reposo y los latch controlan adecuadamente el preset que tiene que estar encendido sin que nosotros hagamos nada mas ;)

:saludo:
Subir
#46 por jose m el 25/10/2009
Dcr te falta un diodo en cada bobina de los reles ya que la corriente de retorno se carga los transistores. :ok:


Subir
#47 por phakkito el 25/10/2009
Estoy usando el multisim de N I.

Un inciso, trabajamos con pulsadores, y el problema que descubri, es que si pulsas te selecciona el preset si, pero en cuanto sueltas el pulsador, lo suelta tambien el chip.

La idea es que pulsas un preset, este quede anclado, pulsas otro preset, desancla el anterior y ancla el pulsado, así sucesivamente.

La programacion en realidad te la dan los switchdip de la salida. Estos excitan los transistores que nosotros previamente hemos indicado al switch.

A nivel simulación, los dos problemas que encontré fueron primero que al arranque podía dar un numero de presets aleatorio. Eso lo tengo solventado.

El segundo problema precisamente la elección de presets y tiempo de reset-anclado del preset pulsado.... he logrado unos 5ms de tiempo. Cuando tenia uno seleccionado, al pulsar otro, este también quedaba anclado, y lo que queremos hacer son bancos de presets.

Ya lo tengo todo preparado para la fase prototipo.. con cuatro presets me dará una idea del funcionamiento real.

Un saludo :ok:
Archivos adjuntos:

La vida es muy peligrosa. No por las personas que hacen el mal, sino por las que se sientan a ver lo que pasa.

Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.

Subir
#48 por David el 25/10/2009
Lo de los diodos en los reles que comenta JoseM es verdad. Al simular con el orcad, si salian unos buenos picos de corriente al apagar los reles. Lo unico que me simulo decentemente el orcad, los transitorios.

phakkito, lo que comentas de los pulsadores es algo que yo suponia que podia pasar por las caracteristicas del circuito y es lo que mas miedo me da de todo el diseño (tambien me paso lo mismo que a ti con el orcad, que las salidas de los latch no se quedaban ancladas :(). Como las entradas C (o LE) y D varian teoricamente al mismo tiempo, cuando pulsamos y dejamos de pulsar el switch de banco, no esta claro si la salida va a quedar fija o no... Segun el orcad no queda fija y segun el proteus si.

La unica forma de comprobarlo bien va a ser montando una pequeña porcion del circuito en una placa de conexiones y trabajar con el; que los simuladores estan muy bien pero luego la realidad te puede tirar para atras en un momento :D

La idea seria hacer que las entradas D se mantuvieran un poquito mas en nivel alto para que la entrada C bajase y el dato se quedase anclado con seguridad. Tocara poner condensadores por ahi ;)

:saludo:

Edit: Veo condensadores ya en tu diseño en las entradas. Pues ya esta :ok:
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo