Ayuda con programacion MIDI

Solucionado
  • 1
Maclauver
#1 por Maclauver el 25/05/2023
Buenos dias!!
Acudo a vosotros dioses del MIDI, aquellos que dominais el MIDI como el que enciende el microondas para calentar la leche.

Tengo una pedalera AMPED 2, la cual para para poder memorizar algunos "preset", tiene que ser mediante MIDI, a lo cual me he pillado el AMPERO CONTROL, por tamaño y precio, me ha parecido muy aconsejable.

Confirmo antes de nada que debería funcionar pues he visto a uno que lo hace pero no he conseguido contactar con el.

El caso es que siguiendo videos y tutoriales, mas o menos he conseguido descifrar como funciona y como meter (en teoria) los comandos, pero no he sido capaz de que funciones.

Os adjunto imagenes de los codigos que viene en las instrucciones de la pedalera por si en algo me he equivocado. Ya solo me queda pensar que el cable que he comprado nuevo en amazon, no funcionara, que podria ser supongo, pero tampoco tengo forma de testearlo.

Como podeis observar, en las imagenes tengo 4 valores que poner.
En el canal midi, pongo omni, aunque ya he visto que la pedalera esta en el 1.
En CC entiendo que es CC y no CP por lo que pone en las instrucciones.
Mi duda esta en si en DATA 1 debo poner el valor que dice "CC Number" y en el DATA 2, 0 o 127, o al reves.
Entiendo que si programos unos de activar y desactivar, debo hacer las 2 opciones....

No se, estoy muy perdido, y ademas como comentaba antes, he probado todas las opciones y no responde, ya no se si es el cable o que.

Y entiendo que el cable midi deber ir en "midi out" en el controlador , y "midi in" en la pedalera.


Grcias de ante mano por la ayuda que se pueda aportar.
Archivos adjuntos ( para descargar)
Captura de pantalla 2023-05-25 a las 9.37.24.png
Captura de pantalla 2023-05-25 a las 9.31.39.png
Subir
OFERTASVer todas
  • Keeley 70th Anniv. HALO Andy Timmons
    299 €
    Ver oferta
  • EarthQuaker Devices 70th Anniv. Plumes S Shredder
    129 €
    Ver oferta
  • -21%
    Harley Benton Fusion-T HH Roasted FBB
    298 €
    Ver oferta
Solución elegida por el creador del hilo (Maclauver)
Tommy Blackbird
#2 por Tommy Blackbird el 25/05/2023
Parece lógico que Data 1 = Number y Data 2 = Value. En la parte superior de la primera captura se ve el comando MIDI final "1 CC 27 0" (canal CC número valor).

Lo que veo es que el CC 27 no corresponde a ninguna función del Amped. Algunos ejemplos:

- Para activar el modelo USA sería CC 1 127 (data1=1, data2=127).
- Para subir el Master Volume CC 16 nnn (data1=16 data2=nnn según el valor de volumen que quieras de 0-127)

Lo que sí me he encontrado a veces, es que hay fabricantes que empiezan a contar desde 0 y otros desde 1, y a veces tienes que añadir o restar 1 para que cuadre, pero esto lo ves muy fácilmente mediante ensayo y error.

Verifica de nuevo en qué canal está escuchando el Amped, aunque enviado con Omni debería cogerlo por cualquier canal.

Maclauver escribió:
Y entiendo que el cable midi deber ir en "midi out" en el controlador , y "midi in" en la pedalera.


Si.

Maclauver escribió:
Entiendo que si programos unos de activar y desactivar, debo hacer las 2 opciones....


No sé si entiendo bien la pregunta.

Si quieres activar el tipo de ampli UK, "CC 2 127".
Si quieres activar la reverb, "CC 86 127"
Si quieres desactivar la reverb, "CC 86 0"

Si quieres hacer hacer varias cosas a la vez (cambiar a UK y además activar Reverb) tendrás que enviar los 2 comandos, si el Ampero Control te lo permite. (Hay cacharros que sólo permiten 1 comando CC por pulsación).
Subir
Maclauver
#3 por Maclauver el 25/05/2023
#2 Hola Mike, gracias por responder.
Pues en principio, como me lo pones, es como lo he hecho.
Esta noche volveré a repasar todos los pasos.
Ya solo se me ocurre, que el cable que pille en amazon, este defectuoso., Ya que es us un midi-jack, a lo mejor no esta bien concebido, ya que el AMPED no tiene clavija de pines, si no mini jack.

Aparte de eso, que supongo reemplazando el cable se soluciona.

Entiendo que si creo un comando activando algo que seria poniendo en "data 2" 127 (que activado y 0 seria apagado), luego deberia crear otro para decirle que cuando vuelva a pulsarlo se apague. No se si me he explicado ejjeje.

Bueno, en conclusión, me ha ayudado algo lo que comentas, por lo menos para saber que no iba muy mal encaminado en cuanto al entendimiento del MIDI, que estoy muy neofito.

1000 gracias!!
Subir
Tommy Blackbird
#4 por Tommy Blackbird el 25/05/2023
Maclauver escribió:
Entiendo que si creo un comando activando algo que seria poniendo en "data 2" 127 (que activado y 0 seria apagado), luego deberia crear otro para decirle que cuando vuelva a pulsarlo se apague. No se si me he explicado ejjeje.


Ostras. Esto ya depende mucho de las opciones que te da la controladora MIDI, y aún así no es sencillo. Me explico:

En primer lugar, no todas las controladoras MIDI te permiten asignar comandos alternos o toggle; solo comandos fijos. Es decir que al botón "A" le asignas un comando "CC 1 127", te va a lanzar siempre ese valor de manera fija, por lo que sólo sirve para activar.

Controladoras avanzadas como las Morningstar te permiten asignar valores diferentes según pulsaciones alternas, de manera que cada pulsación alterna te envía uno u otro (sería poder asignar 2 "Data 2" diferentes).

Y aún así, no hay certeza de que funcione correctamente, porque el MIDI no da información del estado de una función: la controladora no sabe si la reverb está o no encendida. Si está encendida y la primera pulsación envía el valor 127, la mantendría encendida y al final habrán hecho falta 2 pulsaciones para apagarla.

Por eso los fabricantes deberían implementar comandos específicos para alternar una función en lugar de tener que mandar un valor 0/127, pero por desgracia eso no siempre sucede.

En resumen, que depende de las opciones que te den la Ampero y el Amped, una en cuanto a mandar comandos y la asignación a los botones, y el otro en cuanto a los comandos que admita.

Al final yo creo que la mayoría de la gente se lo plantea en modo "Preset". En plan simplificado: El botón "A" es para limpio (mandas comandos de ampli UK, reverb ON, y volumen n), Botón "B" para rítmica crunch (ampli USA + reverb OFF), Botón "C" para solos (ampli USA + reverb ON + volumen N+100).

Salvo que tengas un secuenciados que te mande los comandos MIDI en base a una línea de tiempo, pero eso ya es otro mundo.

PD
Maclauver escribió:
#2 Hola Mike, gracias por responder.

¿quién es Mike?
Subir
Maclauver
#5 por Maclauver el 25/05/2023
#4 Jooooder como tengo la cabeza, te he puesto Mike porque yo que se....
1000 perdones.

Pues si que es complicado esto.
En refencia a lo que comentas de si da la opcion la ampero, si, tiene la opciones de elegir, solo pulsar 1 vez, 2 veces, dejar apretado y solo un toque.
En la version de pulsar 2 veces, tienes 2 grupos para crear los midis.

Si está muy completa, y ya te digo que estoy seguro que debe de funcionar porque he visto un tio en youtube que lo hace, pero no he podido contactar con el, así que me toca trastear, y como nunca he hecho nada en MIDI, no se si estaba haciendo lo correcto.
Pero bueno, mas o menos creo que lo tengo medio claro.

Solo me queda probar con otro cable, y nada, ensayo y error como tu bien has dicho.....
Si lo consigo te lo digo jeejje.

Te paso el video del colega por curiosidad.


https://www.youtube.com/watch?v=B3byG68nbp4&t=31s
Subir
Tommy Blackbird
#6 por Tommy Blackbird el 25/05/2023
Maclauver escribió:
Solo me queda probar con otro cable, y nada, ensayo y error como tu bien has dicho.....


¿El cable que has pillado es MIDI Din5 a MIDI Din5 o MIDI Din5 a - TRS (jack stereo)?
Subir
Maclauver
#7 por Maclauver el 25/05/2023
#6 MIDI 5 PINES - mini jack stereo.
Porque el amped no tiene entrada midi, tiene jack.
Asi que como viene unos adaptadores, voy a pillar un cable normal, MIDI-MIDI, a ver si he tenido la mala suerte de que falle el cable.
Subir
Tommy Blackbird
#8 por Tommy Blackbird el 25/05/2023
Maclauver escribió:
Asi que como viene unos adaptadores, voy a pillar un cable normal, MIDI-MIDI, a ver si he tenido la mala suerte de que falle el cable.


Eso te iba a decir, que he leído en el manual que te viene un adaptador. De todas maneras, si tienes a mano un polímetro o comprobador de continuidad, lo mismo puedes probar el cable. Lo que pasa es que no sé si a día de hoy los conectores MIDI - jack son un estándar o cada fabricante lo hace a su rollo.

Si te fijas en esta ilustración, https://sc1.musik-produktiv.com/pic-010145981_02xxl/rockboard-flat-trs-to-midi-cable-trs-midi-type-a-30-cm.jpg
hay un tipo A y un tipo B que van puenteados de forma diferente. La tierra es igual, pero la punta y el anillo van intercambiados.
Subir
Maclauver
#9 por Maclauver el 25/05/2023
#8
Pues vete a saber.
A lo mejor viene todo por ahi.
Ante la duda, he pillado un midi-midi normal, a ver si suena la flauta porque me estoy volviendo loco con este tema ejjeje.
De todas formas gracias por la ayuda, me ha venido genial, para quitarme dudas.
Subir
lutop
#10 por lutop el 25/05/2023
#7

Los cables MIDI-TRS los carga el diablo. Hay varios tipos, segun la marca del aparato y algunos no son para MIDI sino para audio.
Tienes link del cable que compraste?
Subir
Maclauver
#11 por Maclauver el 25/05/2023
#10

https://amzn.eu/d/2CchlKn

Ahora que leo la descripción a lo mejor está ahí el problema.

Ahora que acuesto al peque voy a trastear con un midi normal que he pillado a ver si está ahí el problema.
Subir
lutop
#12 por lutop el 25/05/2023
#11
Ese cable casi seguro que no te sirve.
Si el AMPED te venia con un adaptador, utilizalo. No veo en ningun sitio si utiliza Type A o Type B...
Subir
Hilos similares
Nuevo post

Regístrate o para poder postear en este hilo