Problema con Dual Foot Switch

#1 por ekaitzupitxu el 11/07/2015
Buenas foreros,

Abro este hilo por si alguien me puede echar un cable (nunca mejor dicho). Hace un par de años compré un mini pedal tipo FS6 de Boss de un tío que los hacía y vendía por internet. Mi intención era acoplarlo a mi pedal Boss RC-3 (loop station). Hasta ahí todo bien y funcionaba perfecto.

Os adjunto foto del pedal, y su funcionamiento es el siguiente:

- Pulsador izquierdo (una pulsación): Detiene el loop.
- Pulsador izquierdo (prolongada): Borra el loop grabado.
- Pulsador derecho (una pulsación): Sube el n° de la pista de loop grabada, hay 99 memorias para guardar.
- Pulsador derecho (pulsación prolongada): Baja el n° de la pista de loop grabada.

Por si las moscas dejo un link de un vídeo de YouTube con una review del pedalillo: https://youtu.be/AWIgRwJv65Y

Y ahora yendo al grano, me ha dejado de funcionar el botón derecho (aunque realmente el importante es el izquierdo, pero me jode igual, jaja). Lo he abierto (como si tuviese idea de electrónica...) más que nada para ver si fallaba alguna soldadura y parece que está todo en orden.

La pregunta es, ¿qué debería comprobar con el polímetro? Pregunta tontísima, lo sé, pero estoy perdidísimo en este tema... :sonrojado:

Me refiero, comprobando la continuidad, casi todas las conexiones de los interruptores tienen continuidad con todas las patillas del jack, no sé si será normal. Sé que tiene que ser un circuito más simple que el mecanismo de un botijo, pero no me da para más... :auch:

Os adjunto unas foticos para ver si me podéis echar una mano, tipo "comprueba tocando no sé cuál y tocando en no sé donde a ver si tiene continuidad..." o lo que sea.

Gracias y un saludo!! :brindis:
Archivos adjuntos:
14366229712011469399088.jpg
BBCode:
1436623010655-1651324320.jpg
BBCode:
1436623084532-577304391.jpg
BBCode:
1436623135948-1873621704.jpg
BBCode:

"Sin musica la vida seria un error" - Friedrich Nietzsche.

Subir
#2 por ekaitzupitxu el 11/07/2015
.

"Sin musica la vida seria un error" - Friedrich Nietzsche.

Subir
#3 por ekaitzupitxu el 11/07/2015
Se me había ocurrido que quizás el problema podía provenir de que el jack hembra al ser estéreo, igual necesitaba que el cable que iba del RC-3 al pedalillo también lo fuera, pero no. Lo he probado con un cable estéreo que tengo y ni siquiera funciona el dpdt que sí que funciona con el cable mono.

No sé....estará fastidiado el dpdt directamente?? de ser así, cómo podría comprobar que está roto el dpdt, hay alguna forma de saberlo?

Saludos!

"Sin musica la vida seria un error" - Friedrich Nietzsche.

Subir
#4 por Heive el 11/07/2015
Aupa.

Lo primero, los pulsadores los puedes comprobar con el polimetro tocando algo de metal donde van los cables, lo pones en continuidad y deberia pitar pulsando o sin pulsar el pulsador, en una de las dos posiciones. Si por lo que sea no va bien, los 3 pines de "despues" son lo mismo, podrias pasar los cables ahi pero si se ha jodido el dpdt no funcionara tampoco.

Por otro lado no se que hace ese pedal en el ampli, pero yo diria que necesitas un jack stereo, ahi tienes la masa en comun para los dos pulsadores y un pulsador irÍa al ring y otro al tip (resumiendo, tienes 3 puntos de conexión y un jack mono tiene 2). Al menos para usar los dos pulsadores, con un jack mono seguramente te funcionaria uno de los dos solamente.

TRS%20jack.jpg
Subir
1
#5 por despista2 el 12/07/2015
En primer lugar, el cable entre el pedal y el footswitch tiene que ser de tipo TRS (con conectores de 3 contactos, lo que tú llamas "stereo"). Si dices que has probado con un cable stereo y no te funciona nada, comprueba que tengas continuidad entre los contactos T, R y S de ambos conectores del cable, porque puede que esté dañado el cable.
Ahora vamos a ver qué modo de funcionamiento necesita tu pedal, porque el FS-6 tiene distintos modos de funcionamiento y tu footswitch emula sólo uno de ellos.
Mide continuidad entre masa y el contacto 1 del conector del footswitch, y luego entre masa y el contacto 2. Luego vuelve a hacerlo pulsando el sw1 mientras mides con el contacto 1 y pulsando el sw2 mientras mides con el contacto 2.
El funcionamiento que presupongo es que los switches sean del tipo "momentary switch" y aprovechen el contacto normalmente abierto. Si estoy en lo cierto, no deberías medir continuidad entre masa y los contactos 1 y 2, y deberías medir continuidad con 1 cuando pulsas SW1 y con 2 cuando pulsas SW2.
Haz las medidas que te he dicho y dime los resultados.
Archivos adjuntos:
FS-6.jpg
BBCode:
Subir
1
#6 por ekaitzupitxu el 13/07/2015
despista2 escribió:
Si dices que has probado con un cable stereo y no te funciona nada, comprueba que tengas continuidad entre los contactos T, R y S de ambos conectores del cable, porque puede que esté dañado el cable.


Joder...al final la mayor tontería del mundo me estaba volviendo loco. El cable TRS era nuevo y sin estrenar, por lo que ni me había planteado que pudiera estar dañado, pero al hacer la comprobación...ZASCA!!! No hay conexión entre los tips... (lo sé, merezco unas collejas :oops2:) Acabo de volver de la tienda con un cable nuevo TRS y funcionan de nuevo correctamente ambos interruptores.

Siento muchísimo el mareo y de verdad, gracias por las respuestas tan curradas que me habéis dado, en serio :aplausos:

Un saludo y de nuevo, mil gracias!!!

"Sin musica la vida seria un error" - Friedrich Nietzsche.

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo